Webhoster bietet bald nur noch PHP 5.4.8

07.12.2012 15:29
#1
Montimontt
Joomshopping forum user no avatar
Name: Montimontt
27.02.2012
Posts: 82
Quote
Webhoster bietet bald nur noch PHP 5.4.8

Hi,

derzeit nutze ich Joomshopping 3.7 mit der PHP-Version 5.2.7. Ich habe viele Anpassungen im Front- und Backend vorgenommen bzw. vornehmen lassen (von meinem Programmierer), weil ich aus Joomshopping einen Online-Marktplatz gemacht habe.

Wenn ich meinen Shop testweise über PHP 5.4 laufen lasse, erscheinen sehr viele Fehler- bzw. Warnmeldungen, wie

Strict Standards: Only variables should be assigned by reference in /homepages/20/***/htdocs/joomla1/administrator/components/com_jshopping/admin.jshopping.php on line 24
Strict Standards: Non-static method JSFactory::loadAdminLanguageFile() should not be called statically in /homepages/20/***/htdocs/joomla1/administrator/components/com_jshopping/admin.jshopping.php on line 26
Strict Standards: Only variables should be assigned by reference in /homepages/20/***/htdocs/joomla1/components/com_jshopping/lib/factory.php on line 205
Strict Standards: Only variables should be assigned by reference in /homepages/20/***/htdocs/joomla1/administrator/components/com_jshopping/admin.jshopping.php on line 29
Strict Standards: Non-static method JSFactory::getConfig() should not be called statically in /homepages/20/***/htdocs/joomla1/administrator/components/com_jshopping/admin.jshopping.php on line 30
Strict Standards: Only variables should be assigned by reference in /homepages/20/***/htdocs/joomla1/components/com_jshopping/lib/factory.php on line 20
Strict Standards: Only variables should be assigned by reference in /homepages/20/***/htdocs/joomla1/components/com_jshopping/tables/config.php on line 25
...
...

Was kann ich tun? Ein Upadte auf Joomshopping 3.12 kann ich ja aufgrund besagter Änderungen nicht einfach so vornehmen, oder? Würde das helfen?

Ich bin dankbar für jede Rückmeldung!!!

Viele Grüße und ein schönes Wochenende!
Montimontt


Joomla: 2.5.8
JoomShopping: 3.7
PHP: 5.2.7
 
07.12.2012 19:03
#2
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16480
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

disable deprecated

Global Configuration
Error reporting: simple

 
13.12.2012 16:49
#3
Montimontt
Joomshopping forum user no avatar
Name: Montimontt
27.02.2012
Posts: 82
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

I did so, but this does not help unfortunately!?

 
13.12.2012 16:58
#4
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16480
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

update joomshopping

or

change

error_reporting(E_ALL & ~E_NOTICE);
to
error_reporting(error_reporting() & ~E_NOTICE);


files
components/com_jshopping/jshopping.php
components/com_jshopping/router.php
administrator/components/com_jshopping/admin.jshopping.php

 
13.12.2012 18:27
#5
Montimontt
Joomshopping forum user no avatar
Name: Montimontt
27.02.2012
Posts: 82
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

Thanks for your quick answer!

I can not update as I said. And changing the code in the files you listed caused no less error warning :(

 
13.12.2012 20:59
#6
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16480
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

I do not understand you.

Errors?

 
16.12.2012 11:42
#7
gerreg
Joomshopping forum user no avatar
Name: gerreg
27.10.2011
Posts: 8
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

Hallo,

nach der Umstellung bei 1und1 auf die PHP Version 5.4 funktinoniert der Shopping Cart nicht mehr. Folgende Fehlermeldung taucht mit den Modulen Jshopping Cart (Module Cart 3.0.2)und Jshopping Cart Ext. (Module Cart Ext 3.0.3) auf:


Strict Standards: Only variables should be assigned by reference in /homepages/5/d67571294/htdocs/treffen/modules/mod_jshopping_cart/mod_jshopping_cart.php on line 23

Strict Standards: Only variables should be assigned by reference in /homepages/5/d67571294/htdocs/treffen/modules/mod_jshopping_cart/mod_jshopping_cart.php on line 27


Kann mir bitte jemand sagen wo ich hier etwas reparieren kann? Oder ist hier noch ein Versionsfehler in den Cart Modulen?

Im Screenshot habe ich zu Anschauung mal beide Cart Mmodule in der Anzeige geschaltet! Im normalen Betrieb, werde ich nur einen Cart aktivieren.

Ich hatte dem Forum versprochen zum heiligen Abend die Buchungsseite frei zu geben, es wäre schön wenn mir bis dahin jemand einen Tip geben kann wo der Fehler liegt.

Danke im voraus!

Aw: Webhoster bietet bald nur noch PHP 5.4.8


Joomla: 2.5.8. Stable DE
JoomShopping: 3.12.2
PHP: 5.4
MySQL: 5.0
Website Url: http://www.treffen-flyingbrick.de

Letzte Änderung: 16.12.2012 11:51
 
16.12.2012 11:52
#8
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16480
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

modules/mod_jshopping_cart/mod_jshopping_cart.php
delete row
error_reporting(E_ALL & ~E_NOTICE);


Letzte Änderung: 16.12.2012 11:52
 
16.12.2012 14:11
#9
gerreg
Joomshopping forum user no avatar
Name: gerreg
27.10.2011
Posts: 8
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

Thank you, for the fast tip! Now its run perfektly! :-)


Letzte Änderung: 16.12.2012 14:12
 
17.12.2012 12:30
#10
Montimontt
Joomshopping forum user no avatar
Name: Montimontt
27.02.2012
Posts: 82
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

With "And changing the code in the files you listed caused no less error warning" I ment, that I changed the code as you wrote but the warning messages still show up!

 
17.12.2012 15:05
#11
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16480
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

Disable deprecated

Joomla / Global Configuration
Error reporting: simple

 
06.01.2013 16:39
#12
Montimontt
Joomshopping forum user no avatar
Name: Montimontt
27.02.2012
Posts: 82
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

This is not working, I still get error messages!?!?!

Changing the code into
error_reporting(0);
helped. Is that ok?


Letzte Änderung: 06.01.2013 17:24
 
06.01.2013 20:58
#13
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16480
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

Joomla version:?

 
09.01.2013 16:34
#14
Montimontt
Joomshopping forum user no avatar
Name: Montimontt
27.02.2012
Posts: 82
Quote
Aw: Webhoster bietet bald nur noch PHP 5.4.8

2.5.8

I could solve all warnings except:

Strict Standards: Declaration of mtLinks::load() should be compatible with JTable::load($keys = NULL, $reset = true) in /components/com_mtree/admin.mtree.class.php on line 1595

Strict Standards: Only variables should be assigned by reference in /components/com_jshopping/lib/functions.php(410) : eval()'d code on line 2

Strict Standards: Declaration of jshopUserShop::check() should be compatible with JTable::check() in /components/com_jshopping/tables/usershop.php on line 448


Joomla: 2.5.8
JoomShopping: 3.5
PHP: 5.4.10

Letzte Änderung: 09.01.2013 16:40
 
Copyrights MAXXmarketing GmbH. All Rights Reserved