PHP Ver 5.4 und Joomshopping

25.11.2012 16:26
#1
matthes
Joomshopping forum user no avatar
Name: Matthias Weber
15.05.2012
Posts: 7
Quote
PHP Ver 5.4 und Joomshopping

Hallo Community,

ich hatte gerade eine Unterhaltung mit einem Supporter von 1und1.
Ende des Jahres wird 1und1 PHP 5.2 zugunsten von PHP 5.4 abstellen.
Da man momentan per Konfiguration im Kundencenter von 1und1 leicht zwischen den beide Versionen hin und er schalten kann, habe ich das mal testweise gemacht. JoomShopping (3.11.0) ist definitiv nicht gut mit der PHP 5.4 zurechtgekommen, ich bekam auf allen möglichen Joomshopping Seiten folgenden Fehler: "Strict Standards: Only variables should be assigned by reference in /Homepage/components/com_jshopping/xxx.php on line xxx"

Steuern wir da gegen Ende des Jahres auf ein Problem zu? Vertragen sich die neuern Versionen von Joomshopping besser mit PHP 5.4?

Vielen Dank für antworten schon jetzt!

Grüße,

Matthes


Joomla: 2.5
JoomShopping: 3.11.0
PHP: Das ist hier die Frage...
 
25.11.2012 16:45
#2
matthes
Joomshopping forum user no avatar
Name: Matthias Weber
15.05.2012
Posts: 7
Quote
Aw: PHP Ver 5.4 und Joomshopping

OK, ich bin einen Schritt weiter:
Die Fehlermeldung ist offensichtlich nur eine Warnmeldung.
Diese kann man in der PHP.ini abstellen (oder bei 1und1 im Kundencenter unter "Lokale PHP-Einstellungen").
Der Shop läuft danach einwandfrei, habe alles durchgetestet.
Ich habe die Warnmeldungen aber immer noch im Administrator auf allen Seiten von JoomShopping

Grüße,

Matthes

 
25.11.2012 18:47
#3
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16475
Quote
Aw: PHP Ver 5.4 und Joomshopping

Joomshopping 3.11.4-3.12.0 (4.0.0) works well
Disable strict.

Global Configuration / server

Error Reporting: Simple

 
Copyrights MAXXmarketing GmbH. All Rights Reserved