Keine Umlaute in Bestätigungsmail

22.07.2015 13:11
#1
Efbege
Joomshopping forum user no avatar
Name: Bernhard Gregor
06.09.2011
Posts: 17
Quote
Keine Umlaute in Bestätigungsmail

Nach einigem vergeblichen Suchen jetzt hier die Frage, wo ich die Darstellung von Umlauten einstellen bzw. ändern kann.

In den statischen Texten, Produktbeschreibungen etc. werden die Umlaute sowie das "ß" am Bildschirm korrekt dargestellt. Im Quelltext etwa der Widerrufsbelehrung der statischen Texte sieht auch alles in Ordnung aus. In den Bestätigungsmails werden diese Zeichen jedoch durch � ersetzt.

Wie bzw. wo läßt sich das berichtigen?

Danke.



I searched, but with no result. That's why here the question how to put the umlauts correct?

In static texts, product descriptions etc. on screen everything is fine. In the source code of static texts, e.g. "Widerrufsbelehrung", everything looks fine. But in the order confirmation (mail) all umlauts are replaced by �.

How to chance resp. correct this?

Thank you.


Joomla: 3.4.3
JoomShopping: 4.10.3
 
22.07.2015 21:53
#2
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16513
Quote
Aw: Keine Umlaute in Bestätigungsmail

email program?

 
22.07.2015 22:39
#3
Efbege
Joomshopping forum user no avatar
Name: Bernhard Gregor
06.09.2011
Posts: 17
Quote
Aw: Keine Umlaute in Bestätigungsmail

Mailprogram is Amicron-Mailoffice 4.0 (www.amicron.de)

 
24.07.2015 14:29
#4
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16513
Quote
Aw: Keine Umlaute in Bestätigungsmail

You change language file?
Try use other (example: gmail)

 
27.07.2015 13:11
#5
Efbege
Joomshopping forum user no avatar
Name: Bernhard Gregor
06.09.2011
Posts: 17
Quote
Aw: Keine Umlaute in Bestätigungsmail

webdesigner - 24.07.2015 14:29
You change language file?

Which language file? My mail program does not have any (that I can see).

webdesigner - 24.07.2015 14:29
Try use other (example: gmail)

What other? Mail program? That's not really an option.

 
27.07.2015 16:25
#6
arcpixx.de
User arcpixx.de
Name: arcpixx
21.01.2012
Posts: 92
Quote
Aw: Keine Umlaute in Bestätigungsmail

Hast du evtl. mal die Datei, die die eMails erzeugt, bearbeitet und versehentlich im falschen Format gespeichert?

Korrekt müsste dieses Format beim speichern sein: "UTF-8 ohne BOM"

 
27.07.2015 17:02
#7
Efbege
Joomshopping forum user no avatar
Name: Bernhard Gregor
06.09.2011
Posts: 17
Quote
Aw: Keine Umlaute in Bestätigungsmail

Ich habe früher zwar die Sprachdateien von JoomShopping bearbeitet (und vor allem den Begriff "Rückgaberecht" durch "Widerrufsrecht" ersetzt, in der aktuellen Version war das aber nicht nötig.

Der Editor speichert in UTF-8 ab (UTF-8 mit BOM wäre eine eigene Option, die jedoch nicht gewählt ist).

Ich habe die aktuelle Sprachdatei (lang--->de-DE.php) im Editor geöffnet, er zeigt mir als Codierung lediglich UTF-8 an.

In den Optionen der Mail der Testbestellung steht:
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 8bit

Ich verstehe nicht, welcher language-file von webdesigner gemeint ist und "was anderes" ich probieren soll.

Das Mailprogramm wechseln ist keine Option, da dies die gleiche Datenbank wie die Fakturierung verwendet.

Sorry, ich stehe etwas auf dem Schlauch.

 
27.07.2015 17:22
#8
arcpixx.de
User arcpixx.de
Name: arcpixx
21.01.2012
Posts: 92
Quote
Aw: Keine Umlaute in Bestätigungsmail

Hmm, also die Mails werden ja nicht (nur) aus der Language-Datei erzeugt. Die Inhalte werden aus den statischen Texten (zum Beispiel Widerrufsbelehrung) gezogen und aus den Inhalten des Shops (also die Bestellung selbst).

Ich denke am ehesten, dass das Durcheinander in der erzeugenden Datei entsteht....ich meine, es müsste die Datei Checkout.php im Ordner Models sein...habe hier im Moment keinen Zugriff auf ftp...vielleicht ist diese Datei mal im falschen Format gespeichert worden?

 
28.07.2015 15:49
#9
Efbege
Joomshopping forum user no avatar
Name: Bernhard Gregor
06.09.2011
Posts: 17
Quote
Aw: Keine Umlaute in Bestätigungsmail

arcpixx.de - 27.07.2015 17:22
Ich denke am ehesten, dass das Durcheinander in der erzeugenden Datei entsteht....ich meine, es müsste die Datei Checkout.php im Ordner Models sein...habe hier im Moment keinen Zugriff auf ftp...vielleicht ist diese Datei mal im falschen Format gespeichert worden?

Von mir nicht, da ich diese Datei nie bearbeitet habe.
Es betrifft z. B. die Absenderangabe, da in der Straße zwei "ü" sind. Aber auch z. B. Produktangaben, die am Bildschirm (Frontend wie Backend) korrekt dargestellt werden, nur in den Mails nicht.

Auf Grund der Äußerung von Webdesigner werde ich versuchen, einen Test mit einem anderen Mailprogramm zu machen. Dazu muß ich aber erst einen Testaccount einrichten (und ein anderes Mailprogramm installieren).


Letzte Änderung: 28.07.2015 15:50
 
Copyrights MAXXmarketing GmbH. All Rights Reserved