Lost Password Function Not Working

26.04.2011 08:02
#1
portman98
Joomshopping forum user no avatar
Name: EHLEE
23.04.2011
Posts: 6
Quote
Lost Password Function Not Working

When I click the lost password function, the system shows me "404-Component Not Found" error message.

Will appreciate if you could tell me the solution for this.

Thanks.

 
26.04.2011 08:11
#2
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16503
Quote
Aw: Lost Password Function Not Working

Lost Password - standart joomla function (not shop)

I think the problem url(SEF).

 
26.04.2011 11:14
#3
portman98
Joomshopping forum user no avatar
Name: EHLEE
23.04.2011
Posts: 6
Quote
Aw: Lost Password Function Not Working

What I meant was the lost password link in the JoomShop customer login form.

Or should I post this question else where, please advise.

Thanks.

 
26.04.2011 12:24
#4
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16503
Quote
Aw: Lost Password Function Not Working

Website URL:?

 
27.04.2011 04:05
#5
portman98
Joomshopping forum user no avatar
Name: EHLEE
23.04.2011
Posts: 6
Quote
Aw: Lost Password Function Not Working

Herewith is my url www.mainstreammultimedia.com for your kind advise please.

The form in under Customer menu.

Thanks.

 
27.04.2011 08:07
#6
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16503
Quote
Aw: Lost Password Function Not Working

bug in joomshoping

will be fixed in new version.


change file

components\com_jshopping\controllers\user.php

replace row
$view->assign('href_lost_pass', SEFLInk('index.php?option=com_user&view=reset'));

to
$view->assign('href_lost_pass', SEFLInk('index.php?option=com_users&view=reset'));



Letzte Ă„nderung: 27.04.2011 08:07
 
28.04.2011 08:57
#7
portman98
Joomshopping forum user no avatar
Name: EHLEE
23.04.2011
Posts: 6
Quote
Aw: Lost Password Function Not Working

After I edited the line with NotePad and uploaded to my hosting server, the login page does not work anymore.

I will unintall and try again, thanks.

 
28.04.2011 14:08
#8
portman98
Joomshopping forum user no avatar
Name: EHLEE
23.04.2011
Posts: 6
Quote
Aw: Lost Password Function Not Working

Error fixed with your line of code.

Many thanks.

 
15.06.2012 13:57
#9
hortitrends
Joomshopping forum user no avatar
Name: Tanya
31.01.2012
Posts: 7
Quote
Aw: Lost Password Function Not Working

Hi I am having the same issue, however I copied the code you suggested above but it still doesn't work. any other suggestions.

The code now reads

$view->assign('href_lost_pass', SEFLInk('index.php?option=com_users&view=reset',0,0, $jshopConfig->use_ssl));


Joomla: 2.5.4
JoomShopping: 3.2.7
 
Copyrights MAXXmarketing GmbH. All Rights Reserved