Not compatible with the plug SEF

23.04.2014 20:54
#1
doc_fbi
Joomshopping forum user no avatar
Name: Doc
04.07.2012
Posts: 7
Quote
Not compatible with the plug SEF

Good afternoon.
The module menu "category" incompatibility with the version found joomla3
This module transmits nepravelno parametor "alias" to the plugin system "SEF". In consequence of that this plugin nepravelno formin tag "canonical." using as main url not alisas and neposredsvenno link module. Please fix this issue in future releases.
Not compatible with the plug SEF


Joomla: 3.2.3
JoomShopping: 4.4.1
PHP: 5.3.5
MySQL: 5.1.53
Website Url: http://www.radio-portal.ru/shop.html
 
23.04.2014 21:55
#2
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16475
Quote
Aw: Not compatible with the plug SEF

name plugin?

 
24.04.2014 04:43
#3
doc_fbi
Joomshopping forum user no avatar
Name: Doc
04.07.2012
Posts: 7
Quote
Aw: Not compatible with the plug SEF

System SEF


Letzte Ă„nderung: 24.04.2014 04:43
 
09.05.2014 11:57
#4
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16475
Quote
Aw: Not compatible with the plug SEF

\components\com_jshopping\router.php

function jshoppingBuildRoute
Add rows

$app = JFactory::getApplication();
$menu = $app->getMenu();
if ($query['Itemid'] && isset($query['controller'])){
$menuItem = $menu->getItem($query['Itemid']);
$micontroller = $menuItem->query['controller'];
if ($micontroller && $query['controller'] && $micontroller==$query['controller']){
unset($query['controller']);
}
}


After
if (isset($query['controller'])){
$controller = $query['controller'];
}else{
$controller = "";
}

 
Copyrights MAXXmarketing GmbH. All Rights Reserved