Payone payment not going through

15.10.2014 17:58
#1
andreidragomir
Joomshopping forum user no avatar
Name: Andrei Dragomir
30.01.2013
Posts: 7
Quote
Payone payment not going through

Hello,

I run a Joomla 3.2.3 website with Joomshopping 4.4.1. I have successfully used payone payment option until this month, when suddently it didn't work anymore. This means that everything in frontend went ok, but in backend there was no order registering. I spoke with the support team in Payone and they told me the transaction URL (which I copied from Joomshopping backend into the payone control panel) is not sendint the correct paramters (GET instead of POST parameters).
I have then decided to update to latest 2.0 version of the payment module, and the system unfortunately did not update the last version, instead added a new payment option. Of course I deactivated the old one, and use the new one and now nothing happens after last step of payment (when it should go to payment page on payone)

Please find below part of the error log generated by the website:
/home/altaseal/public_html/components/com_jshopping/payments/pm_payone/pm_payone.php on line 339
[15-Oct-2014 14:25:30 UTC] PHP Strict Standards: Declaration of pm_payone::showEndForm() should be compatible with PaymentRoot::showEndForm($pmconfigs, $order) in /home/altaseal/public_html/components/com_jshopping/payments/pm_payone/pm_payone.php on line 339
[15-Oct-2014 15:46:12 UTC] PHP Strict Standards: Declaration of pm_payone::showEndForm() should be compatible with PaymentRoot::showEndForm($pmconfigs, $order) in /home/altaseal/public_html/components/com_jshopping/payments/pm_payone/pm_payone.php on line 281
[15-Oct-2014 15:46:14 UTC] PHP Strict Standards: Declaration of pm_payone::showEndForm() should be compatible with PaymentRoot::showEndForm($pmconfigs, $order) in /home/altaseal/public_html/components/com_jshopping/payments/pm_payone/pm_payone.php on line 281
[15-Oct-2014 15:46:19 UTC] PHP Strict Standards: Declaration of pm_payone::showEndForm() should be compatible with PaymentRoot::showEndForm($pmconfigs, $order) in /home/altaseal/public_html/components/com_jshopping/payments/pm_payone/pm_payone.php on line 281


I can provide you with full access to the website, however I can not post FTP details here public.


Joomla: 3.2.3
JoomShopping: 4.4.1
PHP: 5.4
Website Url: www.altaseal.de
 
15.10.2014 19:39
#2
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16485
Quote
Aw: Payone payment not going through

Install PayOne.de 2.0.1

 
15.10.2014 23:36
#3
andreidragomir
Joomshopping forum user no avatar
Name: Andrei Dragomir
30.01.2013
Posts: 7
Quote
Aw: Payone payment not going through

Ok I did this, and still can not get past the last step. Whenever I click "Buy" from last step, the page reloads and I get back to the same page. This time though, nothing is present in the error log. Can you please take a look into the website / ftp ? How can I provide the credentials privately ?
Aw: Payone payment not going through

 
15.10.2014 23:38
#4
andreidragomir
Joomshopping forum user no avatar
Name: Andrei Dragomir
30.01.2013
Posts: 7
Quote
Aw: Payone payment not going through

Also, the payment doesn't go through Payone control panel > Transaction status, as it did before with payone 1.0.4 module.

It can not connect to the Payone api, see screenshot please. FYI I have tried multiple times to make a test order after last hour present there (15-10-2014, 4:29PM) and nothing comes through. Also the order does not register into Joomla admin at all.
Aw: Payone payment not going through


Letzte Ă„nderung: 15.10.2014 23:40
 
16.10.2014 08:26
#5
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16485
Quote
Aw: Payone payment not going through

Send me
url?
admin login?
ftp?
Payone test account?


Aw: Payone payment not going through

Status paid - bug??


Letzte Ă„nderung: 16.10.2014 08:26
 
16.10.2014 10:19
#6
andreidragomir
Joomshopping forum user no avatar
Name: Andrei Dragomir
30.01.2013
Posts: 7
Quote
Aw: Payone payment not going through

I have sent you 2 private messages with all the login details.
NOTE: Please use the second message for the correct FTP data, the first message contains the wrong file.

Thank you!

 
16.10.2014 12:14
#7
webdesigner
(Support Team)
User webdesigner
Name: Admin
05.08.2010
Posts: 16485
Quote
Aw: Payone payment not going through

1. Problem in your CSS

DELETED

#tr_payment_pm_payone {
display: none !important;
}

2. problem in your template jomla (Not display message)

NEED ADD
<jdoc:include type="message" />

(Added)

 
Copyrights MAXXmarketing GmbH. All Rights Reserved